Support » Installing WordPress » WordPress 6.4 upgrade problem

  • Good afternoon, i receieved a message from my email that my wordpress was upgraded to 6.4. Ever since then, i cant perform must functions like editing, installing plugins and also updating plugins. Pls, i need urgent help.

Viewing 5 replies - 1 through 5 (of 5 total)
  • rpp

    (@rpfaffenbach)

    You can try the following:
    In /wp-includes/Requests/src/Transport/Curl.php replace the following lines (don’t forget to backup the file!):

    Comment this line
    const CURL_7_22_0 = 0x071600;
    to
    /* const CURL_7_22_0 = 0x071600; */
    
    and around line 366 comment
    
    if ($this->version < self::CURL_7_22_0 && !isset($headers['Connection'])) {
    
    and replace it with
    
    if (!isset($headers['Connection'])) {
    
    

    After this changes you will be able to update your Plugins and perhaps also the comming bugfix from wordpress 6.4.1

    rpp

    (@rpfaffenbach)

    Thread Starter odera100

    (@odera100)

    @rpfaffenbach Thank you for reaching out. I am new to wordpress. Pls, how do i go to /wp-includes/Requests/src/Transport/Curl.php

    • This reply was modified 3 months, 3 weeks ago by odera100.
    rpp

    (@rpfaffenbach)

    @odera100 you’re welcome.
    You need an FTP program and connect to the hoster’s server. The access data should have been provided by the provider.
    Or you log in via the hoster (cPanel or Plesk) and can search/edit the file from there. Please be sure to make a backup before making any changes!

    rpp

    (@rpfaffenbach)

    The problem was fixed with version 6.4.1 of wordpress. Maybe the update will work.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.