Support » Installing WordPress » Still can’t get install.php to execute

  • Resolved Perrorist

    (@perrorist)


    When I click on install.php, it displays the code in the browser. I have reinstalled XAMPP and WP and ensured that .php invokes a browser, and I’m now out of ideas.

    I’ve installed WP many times before, though not recently, and I understand the process.

    I welcome any help or workarounds. Thanks.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Moderator bcworkz

    (@bcworkz)

    You’ve started Apache and MySQL in XAMPP, right? Just checking šŸ™‚
    Where are you clicking on install.php?

    Entering localhost/wp-admin/install.php (or similar if you use a different alias for localhost) into your browser’s address field should start the process.

    Thread Starter Perrorist

    (@perrorist)

    Just checked and see that Apache has stopped. Restarted it and it shut down again. Here’s the error log:

    [Thu Aug 11 15:07:33.868208 2022] [ssl:warn] [pid 18600:tid 444] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
    [Thu Aug 11 15:07:33.958484 2022] [ssl:warn] [pid 18600:tid 444] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
    [Thu Aug 11 15:07:33.994221 2022] [mpm_winnt:notice] [pid 18600:tid 444] AH00455: Apache/2.4.53 (Win64) OpenSSL/1.1.1n PHP/7.4.29 configured -- resuming normal operations
    [Thu Aug 11 15:07:33.994716 2022] [mpm_winnt:notice] [pid 18600:tid 444] AH00456: Apache Lounge VC15 Server built: Mar 16 2022 15:48:38
    [Thu Aug 11 15:07:33.994716 2022] [core:notice] [pid 18600:tid 444] AH00094: Command line: 'S:\\XAMPP\\apache\\bin\\httpd.exe -d S:/XAMPP/apache'
    [Thu Aug 11 15:07:34.001633 2022] [mpm_winnt:notice] [pid 18600:tid 444] AH00418: Parent: Created child process 36716
    [Thu Aug 11 15:07:35.366625 2022] [ssl:warn] [pid 36716:tid 428] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
    [Thu Aug 11 15:07:35.455409 2022] [ssl:warn] [pid 36716:tid 428] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
    [Thu Aug 11 15:07:35.499594 2022] [mpm_winnt:notice] [pid 36716:tid 428] AH00354: Child: Starting 150 worker threads.
    Thread Starter Perrorist

    (@perrorist)

    I fixed that problem, but it wasn’t the cause. Checking the access.log I see

    ::1 - - [12/Aug/2022:02:27:25 +1000] "OPTIONS /ROOT/subscription%3ANTEventLogEventConsumer.Name%3D%22SCM%20Event%20Log%20Consumer%22 HTTP/1.1" 200 - "-" "Microsoft-WebDAV-MiniRedir/10.0.19043"
    ::1 - - [12/Aug/2022:02:27:25 +1000] "PROPFIND /ROOT/subscription%3ANTEventLogEventConsumer.Name%3D%22SCM%20Event%20Log%20Consumer%22 HTTP/1.1" 405 320 "-" "Microsoft-WebDAV-MiniRedir/10.0.19043"
    ::1 - - [12/Aug/2022:02:27:25 +1000] "PROPFIND /ROOT HTTP/1.1" 405 320 "-" "Microsoft-WebDAV-MiniRedir/10.0.19043"

    Unfortunately, that doesn’t explain to me why it stops as soon as it starts. There’s nothing in the error log.

    Moderator bcworkz

    (@bcworkz)

    Making an unsupported PROPFIND request shouldn’t cause Apache to stop running. No other clues in the control panel’s startup log? I recommend asking for help over at Apache Friends forums where those more familiar with XAMPP can help you.
    https://community.apachefriends.org/f/

    Dion

    (@diondesigns)

    You should check the Windows event viewer for Apache-related messages.

    You should also change the Apache Listen directive(s) to only listen to 127.0.0.1:80, and 127.0.0.1:443 if your localhost setup supports SSL. That will stop Windows applications from making HTTP requests to ::1 (the IPv6 version of 127.0.0.1). Example:

    Listen 127.0.0.1:80
    <IfModule ssl_module>
        Listen 127.0.0.1:443
    </IfModule>
    Thread Starter Perrorist

    (@perrorist)

    Thanks for all the responses. I did go to the Apache forum and now have Apache remaining open. However, I still can’t get .php to execute is, so e in the same way as a .html. All I see is a PHP code displayed in the browser. I’ve tried different browsers and Firefox says that PHP isn’t running, even though Apache is running. I need to go back to the Apache forum.

    Thread Starter Perrorist

    (@perrorist)

    Turns out I should have used localhost for the install. I distinctly recall being able to execute PHP code from File Explorer. At least I now know where I went wrong.

    Thanks for all the helpful suggestions.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.