Support » Installing WordPress » Turning off comments

  • Resolved yebaws

    (@yebaws)


    I have comments turned off for posts, but keep getting spam comments. Notification email typically starts something like:
    “A new comment on the post “Sourdough Bread” is waiting for your approval”
    There isn’t a post “Sourdough Bread” on the site, in fact there are no posts at all, only static pages.
    When I go to look at the comment in admin, I find that it is “in response to Sourdough Bread” and it shows a picture of sourdough bread (don’t seem to be able to attach a screenshot here), which is just a jpeg, not a page or a post.
    How is this getting through and how can I stop them?
    Thanks

Viewing 6 replies - 1 through 6 (of 6 total)
  • Sania Mohammadi

    (@saniamohammadi)

    Hi @yebaws,

    To stop receiving spam comments, you can try these steps and check which one works:

    • Update your WordPress, plugins, and themes to the latest versions and disable/delete the unused ones to see if it resolves the issue.
    • Check your comment settings on WordPress again to make sure you have to approve comments manually. 
    •  Add a CAPTCHA or reCAPTCHA to your comment forms.
    • Alternatively, you can use an anti-spam plugin or enable comment filtering options.

    Hope it helps! Let me know if you have other questions.

    Thread Starter yebaws

    (@yebaws)

    Hello @saniamohammadi

    • themes / plugins etc are all up to date
    • comments are definitely turned off
    • I have one contact form with a captcha – it works as I’m not spammed through that. I don’t have any comment forms because there are no posts (only pages) and comments are turned off.

    I’m thinking the easiest way might be to just delete / rename the page that the comments are sent through. Would that be comment.php?

    Sania Mohammadi

    (@saniamohammadi)

    Another thing here, since WordPress treats media files as post types, spammers might have included their links in file URLs. Please also try disabling comments for media attachments and see if it works here.

    Thread Starter yebaws

    (@yebaws)

    Thanks. Hopefully that plugin will do the trick

    Hello yebaws, you can try some plugins to disable comments, That worked for me.

    Thread Starter yebaws

    (@yebaws)

    Thank you for your suggestions

    I installed the “disable comments” plugin to disable comments on images. This did the trick. Why just “disabling all comments” in the main admin doesn’t do that, I don’t know.

    I never cease to be amazed by the complexity / interdependencies of WordPress. A separate plugin is needed to do the tiniest little thing, so you end up with dozens of plugins. One of them breaks due to an update and the whole site goes down. Somebody really needs to start again from the beginning with WordPress (not me though!).

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.